安装jabberd时,出现Libidn >= 0.3.0 not found 问题

安装jabberd时,出现:

checking for stringprep_check_version in -lidn... yes
checking for Libidn version >= 0.3.0... no
configure: error: Libidn >= 0.3.0 not found

这样的问题呢?libidn这个库已经存在。

[~@serv_1 jabberd-2.2.9]# rpm -qa | grep libidn
libidn-0.6.5-1.1
libidn-devel-0.6.5-1.1

libidn这个库我确实也已经安装了,为什么还是会出现这样的问题呢?不明白?
查了资料说,要么没有libidn这个库,要么就是库的路径不对,但我的库都是装在系统默认的环境变量所指的目录里的。/usr/include /usr/lib。没有理由找不到啊!!
不解!!

机器人 2009-10-30 17:10 于 北京 阴

此条目发表在 linux/server 分类目录,贴了 , 标签。将固定链接加入收藏夹。

安装jabberd时,出现Libidn >= 0.3.0 not found 问题》有 3 条评论

  1. zhang 说:

    问题解决了么?
    我今天也在编译jabberd2也遇到和你同样的问题,网上搜索搜到这里了。

  2. wang 说:

    我今天也在编译jabberd2也遇到和你同样的问题,网上搜索搜到这里了。

  3. I’ve never seemed at it like that, but you have got introduced to brain some things I’ve never considered within the past. I am aware this was not an exceptionally really serious topic, but I do appreciate what you explained. I’ll be studying your weblog more usually.

发表评论

电子邮件地址不会被公开。 必填项已用*标注

您可以使用这些HTML标签和属性: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>